Skip to main content

Reply to this post | See parent post | Go Back
View Post [edit]

Poster: Tyler Date: Jan 19, 2012 8:06am
Forum: movies Subject: Re: new video/audio player 'opt in' is live!

Works great in Chrome

A few initial impressions (on the Live Music Archive / audio player version only, not video)

ex:
http://www.archive.org/details/jj2008-06-14.mk4

1. I like the bigger 'font' in the streaming player.
2. I kind of like how when you click a song it makes that song the 'top' song on the player's display list / it auto scrolls down so the blue 'clicked on' song is the top one.
3. PROBLEM: cannot seem to 'seek' using the seek bar to jump to a part in the song, no matter how long you wait to allow it to buffer.
4. Time disparities between what the player list says a track length is, and how long it says the length is on the actual track player as it is playing in the upper right corner. Usually a 5-6 second disparity, and the time listed in the player list usually is the 'true' time of the track.
5. the 'share' button fades in / out every few seconds instead of being static. Intentional?
6. Clicking the 'share' button, you get the embed code and the "Video Link" (even for 'audio' shows. perhaps make a more open text choice? like "Media Link" ?
7. Also for an audio concert show, having a big red X over the 'Video Link' section made me think that because this was a concert the 'Video Link' URL didn't apply / was greyed out (though I think it is just placement of the 'close' X button that glows red and changes to black when hovered over.
8. The "For more formats and information:" it isn't that clear that you are hoping the user click on the roman-style archive-icon. It kind of is, but I think the user / eye keeps going down to the 2nd line 'Embedding tips and help'. maybe change "For more formats and information" to "Media Details Page" ? or "Item Detail Page" ? ..
9. the 'help' link linked to "Embedding tips and help": http://www.archive.org/help/video.php is pretty 'new', and I understand this feature is mostly for video and audio just got lumped into it, but could you add something about audio on the linked page?

Just a few observations. Thanks archive.org / Tracey for always keeping improvements on the lookout for the user's experience!


Going to any pages on archive.org that have the new streaming crashes IE and asks to send an error report to Microsoft. (v 7.0.57) for some reason. archive.org loads fine, http://www.archive.org/web/web.php is fine, http://www.archive.org/details/software is fine, just when i click on the Live Music Archive and then get to a page with the streaming player on it, it crashes with the below info:

AppName: iexplore.exe AppVer: 7.0.6000.17103 ModName: mshtml.dll ModVer: 7.0.6000.17104 Offset: 0002efb1

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Jan 19, 2012 1:36pm
Forum: movies Subject: Re: new video/audio player 'opt in' is live!


> 6. Clicking the 'share' button, you get the embed code and the "Video Link" (even for 'audio' shows. perhaps make a more open text choice? like "Media Link" ?

partial/mostly fixed 8-)

ok, I've updated it to be "Audio link" instead of "Video link" for audio items, at least in the "html5" / "audio tag" variant (unfortunately IE7 and IE8 use a flash plugin variant so they will still say "Video link", at least for now)

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Jan 19, 2012 2:13pm
Forum: movies Subject: Re: new video/audio player 'opt in' is live!


(9)
good idea! ok brand new http://www.archive.org/help/audio.php page
and audio items will point to that instead.

Reply to this post
Reply [edit]

Poster: Tyler Date: Jan 19, 2012 8:34am
Forum: movies Subject: Re: new video/audio player 'opt in' is live!

P.S. the old 'doesn't automatically go to the next track / autoplay issue is still happening. the old < audio > link / player / trick seemed to fix it a year ago, but maybe it's back? it's a hard to reproduce problem.

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Jan 19, 2012 12:28pm
Forum: movies Subject: Re: new video/audio player 'opt in' is live!

yah, i think the new player should handle "auto advance" just fine in all browsers and even mobile setups like iOS and android.

The Plan is to convert everyone to the new player soon (days, weeks at most i hope!) so that should fix things, right, since everything will use the new player?
-tracey

Reply to this post
Reply [edit]

Poster: Tyler Date: Jan 19, 2012 12:19pm
Forum: movies Subject: Re: new video/audio player 'opt in' is live!

*The 'seek' ability now seems to be fixed
*the times are now correct in the list vs when the track is played
*I like the 'copy' buttons next to the 'embed' section and the URL section in the 'share' button.
*nice larger 'buttons'

Nice improvements from this AM!

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Jan 19, 2012 1:29pm
Forum: movies Subject: Re: new video/audio player 'opt in' is live!

wow, great thoughtful comments as always, Tyler, thanks!

> 5. the 'share' button fades in / out every few seconds instead of being static. Intentional?

no! 8-) minor glitch/oversight as we ended up rolling out the new player a bit early for the IE7/IE8 folks after my bug with old/flowplayer...

should be fixed now -- it should stay visible now.